import Foundation
let pattern = #"[&|;]?Adresa_Drzava(\=[^&;]*)?(?=&|;|$)|^$Adresa_Drzava(\=[^&;]*)?(&|;|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"?&Adresa=dddddddd;Adresa_Drzava=Ma%C4%91arska;substring=0&catid=&Adresa_Mjesto_Naselje=&Adresa_Postanski_Broj=&mh=15"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)