$re = '/[&|;]?Adresa_Drzava(\=[^&;]*)?(?=&|;|$)|^$Adresa_Drzava(\=[^&;]*)?(&|;|$)/';
$str = '?&Adresa=dddddddd;Adresa_Drzava=Ma%C4%91arska;substring=0&catid=&Adresa_Mjesto_Naselje=&Adresa_Postanski_Broj=&mh=15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);