const regex = /[&|;]?Adresa_Drzava(\=[^&;]*)?(?=&|;|$)|^$Adresa_Drzava(\=[^&;]*)?(&|;|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[&|;]?Adresa_Drzava(\\=[^&;]*)?(?=&|;|$)|^$Adresa_Drzava(\\=[^&;]*)?(&|;|$)', 'g')
const str = `?&Adresa=dddddddd;Adresa_Drzava=Ma%C4%91arska;substring=0&catid=&Adresa_Mjesto_Naselje=&Adresa_Postanski_Broj=&mh=15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}