import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[&|;]?Adresa_Drzava(\\=[^&;]*)?(?=&|;|$)|^$Adresa_Drzava(\\=[^&;]*)?(&|;|$)";
final String string = "?&Adresa=dddddddd;Adresa_Drzava=Ma%C4%91arska;substring=0&catid=&Adresa_Mjesto_Naselje=&Adresa_Postanski_Broj=&mh=15";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}