import Foundation
let pattern = #"""
^(?:
(
(?:bool|char|str)
|(?:[fiu](?:32|64))
|(?:[iu](?:8|16|128|size))
)|(
_*[A-Z][a-zA-Z0-9_]*
)
)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
hello world
str
string
String
CString
bool
boolean
Boolean
isize
usize
u128
I64
u_32
0i16
uu8
i4
char
Char
_char
_Char
character
_character
T
N
Type
NUM
snake_case
camelCase
PascalCase
SCREAMING_SNAKE_CASE
_snake_case1
_camelCase2
_PascalCase3
_SCREAMING_SNAKE_CASE4
1snake_case
2camelCase
3PascalCase
4SCREAMING_SNAKE_CASE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)