const regex = new RegExp('^(?:
(
(?:bool|char|str)
|(?:[fiu](?:32|64))
|(?:[iu](?:8|16|128|size))
)|(
_*[A-Z][a-zA-Z0-9_]*
)
)$', 'gm')
const str = `hello world
str
string
String
CString
bool
boolean
Boolean
isize
usize
u128
I64
u_32
0i16
uu8
i4
char
Char
_char
_Char
character
_character
T
N
Type
NUM
snake_case
camelCase
PascalCase
SCREAMING_SNAKE_CASE
_snake_case1
_camelCase2
_PascalCase3
_SCREAMING_SNAKE_CASE4
1snake_case
2camelCase
3PascalCase
4SCREAMING_SNAKE_CASE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}