import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\n"
+ " (\n"
+ " (?:bool|char|str)\n"
+ " |(?:[fiu](?:32|64))\n"
+ " |(?:[iu](?:8|16|128|size))\n"
+ " )|(\n"
+ " _*[A-Z][a-zA-Z0-9_]*\n"
+ " )\n"
+ ")$";
final String string = "hello world\n\n"
+ "str\n"
+ "string\n"
+ "String\n"
+ "CString\n\n"
+ "bool\n"
+ "boolean\n"
+ "Boolean\n\n"
+ "isize\n"
+ "usize\n"
+ "u128\n"
+ "I64\n"
+ "u_32\n"
+ "0i16\n"
+ "uu8\n"
+ "i4\n\n"
+ "char\n"
+ "Char\n"
+ "_char\n"
+ "_Char\n"
+ "character\n"
+ "_character\n\n"
+ "T\n"
+ "N\n"
+ "Type\n"
+ "NUM\n\n"
+ "snake_case\n"
+ "camelCase\n"
+ "PascalCase\n"
+ "SCREAMING_SNAKE_CASE\n\n"
+ "_snake_case1\n"
+ "_camelCase2\n"
+ "_PascalCase3\n"
+ "_SCREAMING_SNAKE_CASE4\n\n"
+ "1snake_case\n"
+ "2camelCase\n"
+ "3PascalCase\n"
+ "4SCREAMING_SNAKE_CASE";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}