#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^(?:" & @CRLF & _
" (" & @CRLF & _
" (?:bool|char|str)" & @CRLF & _
" |(?:[fiu](?:32|64))" & @CRLF & _
" |(?:[iu](?:8|16|128|size))" & @CRLF & _
" )|(" & @CRLF & _
" _*[A-Z][a-zA-Z0-9_]*" & @CRLF & _
" )" & @CRLF & _
")$"
Local $sString = "hello world" & @CRLF & _
"" & @CRLF & _
"str" & @CRLF & _
"string" & @CRLF & _
"String" & @CRLF & _
"CString" & @CRLF & _
"" & @CRLF & _
"bool" & @CRLF & _
"boolean" & @CRLF & _
"Boolean" & @CRLF & _
"" & @CRLF & _
"isize" & @CRLF & _
"usize" & @CRLF & _
"u128" & @CRLF & _
"I64" & @CRLF & _
"u_32" & @CRLF & _
"0i16" & @CRLF & _
"uu8" & @CRLF & _
"i4" & @CRLF & _
"" & @CRLF & _
"char" & @CRLF & _
"Char" & @CRLF & _
"_char" & @CRLF & _
"_Char" & @CRLF & _
"character" & @CRLF & _
"_character" & @CRLF & _
"" & @CRLF & _
"T" & @CRLF & _
"N" & @CRLF & _
"Type" & @CRLF & _
"NUM" & @CRLF & _
"" & @CRLF & _
"snake_case" & @CRLF & _
"camelCase" & @CRLF & _
"PascalCase" & @CRLF & _
"SCREAMING_SNAKE_CASE" & @CRLF & _
"" & @CRLF & _
"_snake_case1" & @CRLF & _
"_camelCase2" & @CRLF & _
"_PascalCase3" & @CRLF & _
"_SCREAMING_SNAKE_CASE4" & @CRLF & _
"" & @CRLF & _
"1snake_case" & @CRLF & _
"2camelCase" & @CRLF & _
"3PascalCase" & @CRLF & _
"4SCREAMING_SNAKE_CASE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")