import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*";
final String string = "/* este es un ejemplo de expresiones \n"
+ " * \n"
+ " * regulares\n"
+ " *\n"
+ " */\n\n"
+ "// Puede ser una cadena \n\n"
+ "/* ldfjsjdfklfj */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}