#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/\*"
Local $sString = "/* este es un ejemplo de expresiones " & @CRLF & _
" * " & @CRLF & _
" * regulares" & @CRLF & _
" *" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"// Puede ser una cadena " & @CRLF & _
"" & @CRLF & _
"/* ldfjsjdfklfj */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")