re = /[^aA-zZ|^\s]+/
str = 'MOHAMMED TUFAIL (Tufail S. M.; Tuffail Sheik Mohammed)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end