using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^aA-zZ|^\s]+";
string input = @"MOHAMMED TUFAIL (Tufail S. M.; Tuffail Sheik Mohammed)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}