package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^aA-zZ|^\s]+`)
var str = `MOHAMMED TUFAIL (Tufail S. M.; Tuffail Sheik Mohammed)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}