$re = '/[^aA-zZ|^\s]+/';
$str = 'MOHAMMED TUFAIL (Tufail S. M.; Tuffail Sheik Mohammed)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);