const regex = /([^,]*,){6}([^,]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^,]*,){6}([^,]*)', '')
const str = `519-48-0195,519480195,AE09430101,160, ,ALEMAN GLORIA ,0065.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}