re = /(.*)([a-z])([A-Z]).*/
str = 'Guadel LondoneLondon'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result