const regex = /(.*)([a-z])([A-Z]).*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)([a-z])([A-Z]).*', 'gs')
const str = `Guadel LondoneLondon`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);