$re = '/(.*)([a-z])([A-Z]).*/s';
$str = 'Guadel LondoneLondon';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;