use strict;
my $str = 'Guadel LondoneLondon';
my $regex = qr/(.*)([a-z])([A-Z]).*/sp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";