import Foundation
let pattern = #"([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?(?:\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\sfor)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Em01_Trq = 500 rpm
Em01_Trq=-500rpm
Em01_Trq<+500rpm in 100ms for 10s
Em01_Trq<=-500rpm for 10s
Em01_Trq>=-500rpm in 10.5s
Em01_Trq>-500.505rpm
Em_md = 1(Torque)
Em_md = 1(Torque) in 50ms
Em_md = 1(Torque)
[Em_md] = 1(Torque) for 50.1min
Em01_Trq = 500 rpm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)