const regex = /([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?(?:\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\sfor)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9_[\\]]+)\\s?((=|<|>|<=|>=)=?)\\s?([-+]?([0-9]*\\.[0-9]+|[0-9]+))\\s?\\(?(\\w*)\\)?(?:\\sfor|\\sin)?\\s?([0-9]*\\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\\sfor)?\\s?([0-9]*\\.[0-9]+|[0-9]+)?(s|ms|min|us)?', 'g')
const str = `Em01_Trq = 500 rpm
Em01_Trq=-500rpm
Em01_Trq<+500rpm in 100ms for 10s
Em01_Trq<=-500rpm for 10s
Em01_Trq>=-500rpm in 10.5s
Em01_Trq>-500.505rpm
Em_md = 1(Torque)
Em_md = 1(Torque) in 50ms
Em_md = 1(Torque)
[Em_md] = 1(Torque) for 50.1min
Em01_Trq = 500 rpm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}