#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z0-9_[\]]+)\s?((=|<|>|<=|>=)=?)\s?([-+]?([0-9]*\.[0-9]+|[0-9]+))\s?\(?(\w*)\)?(?:\sfor|\sin)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?(?:\sfor)?\s?([0-9]*\.[0-9]+|[0-9]+)?(s|ms|min|us)?"
Local $sString = "Em01_Trq = 500 rpm" & @CRLF & _
"Em01_Trq=-500rpm" & @CRLF & _
"Em01_Trq<+500rpm in 100ms for 10s" & @CRLF & _
"Em01_Trq<=-500rpm for 10s" & @CRLF & _
"Em01_Trq>=-500rpm in 10.5s" & @CRLF & _
"Em01_Trq>-500.505rpm" & @CRLF & _
"Em_md = 1(Torque)" & @CRLF & _
"Em_md = 1(Torque) in 50ms" & @CRLF & _
"Em_md = 1(Torque) " & @CRLF & _
"[Em_md] = 1(Torque) for 50.1min" & @CRLF & _
"Em01_Trq = 500 rpm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")