re = /(?:https?:\/\/)?(?:www\.)?nitroflare\.com\/view\/([a-zA-Z0-9]+)\/.+/m
str = 'https://nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end