package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/)?(?:www\.)?nitroflare\.com\/view\/([a-zA-Z0-9]+)\/.+`)
var str = `https://nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}