$re = '/(?:https?:\/\/)?(?:www\.)?nitroflare\.com\/view\/([a-zA-Z0-9]+)\/.+/m';
$str = 'https://nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);