const regex = /(?:https?:\/\/)?(?:www\.)?nitroflare\.com\/view\/([a-zA-Z0-9]+)\/.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?(?:www\\.)?nitroflare\\.com\\\/view\\\/([a-zA-Z0-9]+)\\\/.+', 'gm')
const str = `https://nitroflare.com/view/845F2436715D1F5/o11d_mini-manual.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}