re = /(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)/m
str = '0.9
-.4
-0.5
9
-6
-1.0e-1
-10.56e-1
2.93847293841270e+16
-4.65981524854648e+16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end