#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)"
Local $sString = "0.9" & @CRLF & _
"-.4" & @CRLF & _
"-0.5" & @CRLF & _
"9" & @CRLF & _
"-6" & @CRLF & _
"-1.0e-1" & @CRLF & _
"-10.56e-1" & @CRLF & _
"2.93847293841270e+16" & @CRLF & _
"-4.65981524854648e+16"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")