use strict;
my $str = '0.9
-.4
-0.5
9
-6
-1.0e-1
-10.56e-1
2.93847293841270e+16
-4.65981524854648e+16';
my $regex = qr/(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}