const regex = /(-?\d*(?:\.?\d*)?(?:e[-+]?\d*)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-?\\d*(?:\\.?\\d*)?(?:e[-+]?\\d*)?)', 'gm')
const str = `0.9
-.4
-0.5
9
-6
-1.0e-1
-10.56e-1
2.93847293841270e+16
-4.65981524854648e+16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}