import Foundation
let pattern = #"(comment_approved\s=\s\'(?:1|0)\')|\(\s(comment_approved\s=\s'0'\sOR\scomment_approved\s=\s'1')\s\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
( comment_approved = '0' OR comment_approved = '1' ) AND ( (CAST(wp_72423799_commentmeta.meta_value AS SIGNED) >= '1409095998') ) AND (wp_72423799_commentmeta.meta_key = 'o2_comment_gmt_modified' )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"( $1$2 OR comment_approved = \'trash\' )"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}