package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(comment_approved\s=\s\'(?:1|0)\')|\(\s(comment_approved\s=\s'0'\sOR\scomment_approved\s=\s'1')\s\)`)
var str = []byte(`( comment_approved = '0' OR comment_approved = '1' ) AND ( (CAST(wp_72423799_commentmeta.meta_value AS SIGNED) >= '1409095998') ) AND (wp_72423799_commentmeta.meta_key = 'o2_comment_gmt_modified' )
`)
var substitution = []byte("( $1$2 OR comment_approved = \'trash\' )")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}