// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(comment_approved\s=\s\'(?:1|0)\')|\(\s(comment_approved\s=\s'0'\sOR\scomment_approved\s=\s'1')\s\)").unwrap();
let string = "( comment_approved = '0' OR comment_approved = '1' ) AND ( (CAST(wp_72423799_commentmeta.meta_value AS SIGNED) >= '1409095998') ) AND (wp_72423799_commentmeta.meta_key = 'o2_comment_gmt_modified' )
";
let substitution = "( $1$2 OR comment_approved = \\'trash\\' )";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}