re = /(?<!cat\s)f(ish|rog)/
str = '"foo catfish fooxcat fish foo cat frogfoo cat fishvfoo cat frog foo dog fish frog fooxfish foo frog"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end