$re = '/(?<!cat\s)f(ish|rog)/';
$str = '"foo catfish fooxcat fish foo cat frogfoo cat fishvfoo cat frog foo dog fish frog fooxfish foo frog"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);