const regex = /(?<!cat\s)f(ish|rog)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!cat\\s)f(ish|rog)', 'g')
const str = `"foo catfish fooxcat fish foo cat frogfoo cat fishvfoo cat frog foo dog fish frog fooxfish foo frog"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}