using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!cat\s)f(ish|rog)";
string input = @"""foo catfish fooxcat fish foo cat frogfoo cat fishvfoo cat frog foo dog fish frog fooxfish foo frog""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}