// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<\/?script.*\/?>(.*<\/script>)?").unwrap();
let string = "asdf<script>qwer</script>zxcv
/><script/> asdf
asdf><script />asdf
asdf> <script asdf/> a
a <script asdf=asdf/><asdf
asdf<script asdf=asdf /> <asdf
asdf<script asdf=asdf a/>
<script>
alert();
</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}