re = /<\/?script.*\/?>(.*<\/script>)?/i
str = 'asdf<script>qwer</script>zxcv
/><script/> asdf
asdf><script />asdf
asdf> <script asdf/> a
a <script asdf=asdf/><asdf
asdf<script asdf=asdf /> <asdf
asdf<script asdf=asdf a/>
<script>
alert();
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end