$re = '/<\/?script.*\/?>(.*<\/script>)?/i';
$str = 'asdf<script>qwer</script>zxcv
/><script/> asdf
asdf><script />asdf
asdf> <script asdf/> a
a <script asdf=asdf/><asdf
asdf<script asdf=asdf /> <asdf
asdf<script asdf=asdf a/>
<script>
alert();
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);