use strict;
my $str = 'asdf<script>qwer</script>zxcv
/><script/> asdf
asdf><script />asdf
asdf> <script asdf/> a
a <script asdf=asdf/><asdf
asdf<script asdf=asdf /> <asdf
asdf<script asdf=asdf a/>
<script>
alert();
</script>';
my $regex = qr/<\/?script.*\/?>(.*<\/script>)?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}