re = /^http:\/\/cheqroom.com\/qr\/([a-z0-9]{8})$/i
str = 'http://cheqroom.com/qr/a47abd3a
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end