package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^http:\/\/cheqroom.com\/qr\/([a-z0-9]{8})$`)
var str = `http://cheqroom.com/qr/a47abd3a
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}