$re = '/^http:\/\/cheqroom.com\/qr\/([a-z0-9]{8})$/i';
$str = 'http://cheqroom.com/qr/a47abd3a
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);