const regex = /^http:\/\/cheqroom.com\/qr\/([a-z0-9]{8})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:\\\/\\\/cheqroom.com\\\/qr\\\/([a-z0-9]{8})$', 'i')
const str = `http://cheqroom.com/qr/a47abd3a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}