$re = '/^[A-Z][a-zA-Z \'.-]*[A-Za-z][^-]$/';
$str = 'Abcd sdf dfg-sdf\'asdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);