package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Z][a-zA-Z '.-]*[A-Za-z][^-]$`)
var str = `Abcd sdf dfg-sdf'asdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}