using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z][a-zA-Z '.-]*[A-Za-z][^-]$";
string input = @"Abcd sdf dfg-sdf'asdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}