const regex = /^[A-Z][a-zA-Z '.-]*[A-Za-z][^-]$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z][a-zA-Z \'.-]*[A-Za-z][^-]$', '')
const str = `Abcd sdf dfg-sdf'asdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}