re = /^(?:(?<protocol>[^:\/]+:))?(?::?\/\/)?(?:(?<user>[^\/:]*)(?::(?<passwd>[^@]*))?@)?(?:(?<host>[\w._-]*))?(?::(?<port>\d*))?(?:(?<path>\/?[^?]*))?(?:(?<search>\?[^#]*))?(?:(?<hash>#.*))?$/
str = 'https://user:pwd@localhost:6677/path/to/a/index.html?k1=v1&k2=v2#12313456'
# Print the match result
str.match(re) do |match|
puts match.to_s
end